Game requires 0.7.2 but love-android-sdl2 is 0.10-alpha

A project to port LÖVE to Android handhelds
Locked
Firstport
Prole
Posts: 3
Joined: Sat Sep 12, 2015 7:17 am

Game requires 0.7.2 but love-android-sdl2 is 0.10-alpha

Post by Firstport » Sat Sep 12, 2015 9:16 am

I just got this compiled correctly. But its throwing up the same error the desktop gives me if I try using the latest Love version .9+

This is mobile screenshot, desktop version is identical. But on desktop using 0.7.2 works perfect fixes blue screen error
http://imgur.com/LFvRjih

Is it possible to get the binary library for the 0.7.2 to use? It seems theres no way to use the older engine

User avatar
slime
Solid Snayke
Posts: 2700
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: Game requires 0.7.2 but love-android-sdl2 is 0.10-alpha

Post by slime » Sat Sep 12, 2015 2:45 pm

The Android port was initially based on the codebase of LÖVE 0.9, which is different enough from 0.7.2's source code to make it less than trivial to back-port it to the older codebase.

Daniel_Cortez
Prole
Posts: 11
Joined: Sun Apr 06, 2014 4:43 pm
Location: Novokuznetsk, Russia

Re: Game requires 0.7.2 but love-android-sdl2 is 0.10-alpha

Post by Daniel_Cortez » Sat Sep 12, 2015 2:47 pm

Firstport wrote:I just got this compiled correctly. But its throwing up the same error the desktop gives me if I try using the latest Love version .9+

This is mobile screenshot, desktop version is identical. But on desktop using 0.7.2 works perfect fixes blue screen error
http://imgur.com/LFvRjih
slime wrote:t.screen in [wiki]love.conf[/wiki] was renamed to t.window in [wiki]0.9.0[/wiki].
Firstport wrote:Is it possible to get the binary library for the 0.7.2 to use? It seems theres no way to use the older engine
If I remember correctly, the Android port was initially based on LÖVE 0.9.0, so I don't think you can get the .apk for 0.7.2.

Edit: got ninja'd by slime.
↑↑↓↓↑↑↑↑

Firstport
Prole
Posts: 3
Joined: Sat Sep 12, 2015 7:17 am

Re: Game requires 0.7.2 but love-android-sdl2 is 0.10-alpha

Post by Firstport » Sat Sep 12, 2015 9:22 pm

Thanks for the reply guys. I manager to get this running 9.2.2 by alliterating the conf, and updating some old calls like get.modes type stuff

It however broke the menu selection. So ive been slowly updating calls one by one. Seems major problem is old arthimatic on "i"??
Anyway maybe this is possible?

Ive managed to get to a point where its no error just black screen on both android and runs windows but menu selction adn main gameA wont start, after i deleted a stuff ike the old arthmatic on highscores and music also special color spectrum option

I believe the problem now is the outdated ways the paddedimages are called and the time delay used to show them, As it black screens now when i deleted the time delay code thats starts the game on both windows now as well as android
Attachments
notimedelayatstart.love
Black screen Both. My latest
(2.72 MiB) Downloaded 56 times
game.love
Deep into it, Black screens android and runs windows no error besides I have to fix menu jumps. Think its the Time delay for running all images that is the problem, as when deleted it black screens both systems. Also GameA will not start
(2.72 MiB) Downloaded 51 times
game.love
Works pc 9.2+!! But menu selection and main gameA wont start
(2.65 MiB) Downloaded 51 times

Locked

Who is online

Users browsing this forum: No registered users and 2 guests