LÖVE does not support iPhone 5 (?)

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
comradesparklepony
Prole
Posts: 7
Joined: Mon Dec 30, 2019 6:57 pm

LÖVE does not support iPhone 5 (?)

Post by comradesparklepony » Wed Apr 22, 2020 12:22 am

LÖVE does not appear to work on the iPhone 5 emulator from Xcode. Running a LÖVE game in Xcode yields the following error:

Code: Select all

Error

wrap_Math.lua:35: Cannot push love object to Lua: unexpected alignment (pointer is 0x7a2453c8 but alignment should be 16)


Traceback

[C]: in function
'_getRandomGenerator'
wrap_Math.lua:35: in main chunk
[C]: at 0x000x0780
[C]: in function 'require'
[C]: in function 'xpcall'
[C]: in function 'xpcall'
(iPhone 5s and later appears to work fine)

My guess is that LÖVE uses a feature that the iPhone 5 isn't compatible with. Consulting the chart at the following link: https://developer.apple.com/library/arc ... atrix.html leads me to believe that LÖVE uses arm64, metal, or opengles-3. If LÖVE uses one of these, then I can list it in a .plist file to say that the device just isn't supported, no big deal.

To recreate, run LÖVE on the iPhone 5 emulator and run a game. The problem has persisted for me no matter what game I run; even a .love file consisting of an empty main.lua still has the error.

I am running MacOS Mojave 10.14.6 on a MacBook (Retina, 12-inch, Early 2015). Xcode version is 11.3.1, LÖVE version is 11.3 .

Thank you.
Attachments
main.love
simplest .love file, just an empty main.lua
(142 Bytes) Downloaded 47 times
Last edited by comradesparklepony on Wed Apr 22, 2020 9:45 pm, edited 1 time in total.

User avatar
slime
Solid Snayke
Posts: 2904
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: LÖVE does not support iPhone 5 (?)

Post by slime » Wed Apr 22, 2020 1:44 am

Does it have the same problem on an actual device? The simulator may not match up with the device's behaviour for that sort of problem.

love doesn't currently require any feature that the iPhone 5 can't provide. That being said, I wouldn't bother supporting such an old device, especially since its hardware is so different from every iPhone released after it (32 bit vs 64 bit).

comradesparklepony
Prole
Posts: 7
Joined: Mon Dec 30, 2019 6:57 pm

Re: LÖVE does not support iPhone 5 (?)

Post by comradesparklepony » Wed Apr 22, 2020 9:25 pm

Unfortunately, I do not have an iPhone 5 to test it on. Admittedly, my main concern is that not supporting the iPhone 5 will prevent it from being accepted onto the App Store. Apple has officially dropped support for iPhone 5, but I'm not sure if I still need to support it in order to get past their approval process. Googling did not lead to a definitive answer, so I'd appreciate any insight.

Thanks for the help!

comradesparklepony
Prole
Posts: 7
Joined: Mon Dec 30, 2019 6:57 pm

Re: LÖVE does not support iPhone 5 (?)

Post by comradesparklepony » Thu Apr 23, 2020 3:30 pm

The iPhone 5 has a screen size of 4 inches, but there's no place for a 4 inch screenshot for the App Store on the App Submission page, so it's looking like I do not need to support the iPhone 5.

comradesparklepony
Prole
Posts: 7
Joined: Mon Dec 30, 2019 6:57 pm

Re: LÖVE does not support iPhone 5 (?)

Post by comradesparklepony » Sun Apr 26, 2020 7:32 pm

My app (metro.drone) was approved by the app store, so it looks like iPhone 5 support is not necessary. Thank you!

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 35 guests